Filius
/

Lernanwendung Internet

Herunterladen

Filius wird kostenlos unter den Bedingungen der Lizenz GNU General Public License (GPL) Version 2 oder Version 3 bereitgestellt.  

Systemvoraussetzung

Ab Filius 1.12 ist im Installationsprogramm für Windows die Java-Laufzeitumgebung enthalten. Eine Installation von Java ist damit keine Voraussetzung mehr, um Filius starten zu können. 

Für alle anderen Varianten gilt, dass ab Filius 1.7 Java 8 für die Nutzung erforderlich ist. Das Erstellen und kompilieren eigener Anwendungen in Filius über den Softwareassistenten erfordert darüber hinaus, dass die Java-Laufzeitumgebung eines JDK verwendet wird. Alle anderen Funktionen sowie die Verwendung bereits vorhandener Anwendungen ist mit jeder Java-Laufzeitumgebung (auch JRE) möglich.

Aktuelle Version: 

Die aktuelle Version ist vom 16. Juni 2022:

Filius 1.14 (Windows/Ubuntu/Zip)  

Das Windows-Installationsprogramm ist ab der Version 1.11 signiert durch SignPath Foundation.

Hinweise zu den Änderungen finden Sie in den Versionshinweisen

Sebastian Broers hat ein Installationspaket für die Nutzung unter MacOS erstellt, das er zur Nutzung bereit stellt. Voraussetzung ist, dass Java auf dem System vorhanden ist:

Filius für MacOS (extern)

Zur Installation unter Linux gibt es außerdem ein extern gepflegtes Flatpak mit integrierter Java-Laufzeitumgebung (Flatpak ist ein Paketformat für Anwendungen mit integrierten Abhängigkeiten): 

Filius Flatpak (extern)

Quelltexte

Die Quelltexte zu Filius sind öffentlich verfügbar unter:

https://gitlab.com/filius1/filius

Eine länger zurückreichende Historie bis Version 1.9 ist hier zu finden:

http://svn.savannah.nongnu.org/viewvc/?root=filius